Closed Thread
Results 1 to 6 of 6

Thread: Windows7 x64 Beta Rendering Performance - Terrible?

  1. #1
    Senior Member MegaPixel's Avatar
    Join Date
    Dec 2002
    Posts
    437

    Name
    Super Dave
    Forum Username
    MegaPixel

    United States

    Default Windows7 x64 Beta Rendering Performance - Terrible?

    Has anyone had a chance to setup a multi-PC backburner render network using Windows 7 beta yet? I’ve noticed that the rendering performance of the Win7 x64 beta server nodes is taking twice, if not 3 times longer on average to complete frames then the WinXP x64 server nodes of equivalent hardware spec. which is puzzling me.

    I’m using a mixed OS network (XP, XP64, Win7 64) here at work. I’m using Windows 2008 Server OS 32bit for the manager PC (to allow for more then 10 concurrent PC connections) and all other server nodes are running Max 2009 Design 64bit - Network is still IPv4 with gigabit connection.

    In doing some individual Win7 beta render node testing, I notcied that on occasion, after prematurly canceling a render job, that the render node PC would not return to its “pre-render” performance level - That is to say there were still process’s running in the background (like extra svhost.exe’s,etc...) eating up valuable processor cycles for no apparent reason and grindign the system to a hault.

    I've also just learned over in the Autodesk Area Forums that Vista x64 has very similar speed problems when rendering.

    At any rate, I was hoping someone could confirm these findings and or perhaps shed some light on how to adjust the OS to overcome these render speed delays? Thanks - Pixel
    Last edited by MegaPixel; March 5th, 2009 at 10:09 AM.

  2. #2
    Veteran Member AJLynn's Avatar
    Join Date
    Aug 2004
    Location
    Boston / Cambridge
    Age
    39
    Posts
    6,396

    Name
    Andrew Lynn
    Forum Username
    AJLynn

    United States

    Default Re: Windows7 x64 Beta Rendering Performance - Terrible?

    I would NOT try using the Windows 7 beta in any serious context. It's beta, you don't know what's wrong with it and what they're going to add/subtract/rewrite, and there's no good reason to be using it. Stick with what you know works - XP64.

  3. #3
    Senior Member MegaPixel's Avatar
    Join Date
    Dec 2002
    Posts
    437

    Name
    Super Dave
    Forum Username
    MegaPixel

    United States

    Default Re: Windows7 x64 Beta Rendering Performance - Terrible?

    Point taken, however let me explain our reasoning for using it.

    We needed to quickly add 6 offline PCs to the render farm for a "finite" amount of time. With budgets "slim" these days, we didn't want to have to purchase 6 additional XP64 seats for what will only be needed for a few months tops. Windows 7 Beta is free to use until August of this year so I figured, what the heck.

    Outside of rendering, the OS actually seems pretty decent and snappy and was also the easiest/quickest install and setup I've ever experienced. I know it's a beta and I'll take whatever I can get out of it, but I was still curious to know if anyone else had a chance to experience and overcome what I'm going through right now.

    Thanks - Pixel

  4. #4
    Veteran Member quizzy's Avatar
    Join Date
    Apr 2002
    Age
    45
    Posts
    1,775

    Name
    Michiel Quist
    Forum Username
    quizzy

    Netherlands

    Default Re: Windows7 x64 Beta Rendering Performance - Terrible?

    When microsoft windows works faster, it usually means higher cpu usage instead of optimizing the actual software.. ;-)

  5. #5
    Veteran Member Justin Hunt's Avatar
    Join Date
    Jan 2005
    Location
    Brisbane
    Age
    43
    Posts
    2,975

    Name
    Justin Hunt
    Forum Username
    Justin Hunt

    Australia

    Default Re: Windows7 x64 Beta Rendering Performance - Terrible?

    we installed win7 on an old P4 with only 500mb ram, supprisingly it runs pretty well. Obviously we're not rendering on it, just having a poke around.

    jhv

  6. #6
    Veteran Member
    Join Date
    Oct 2003
    Location
    medfield, ma
    Posts
    885

    Name
    Peter Gruhn
    Forum Username
    Peter M. Gruhn

    United_States

    Default Re: Windows7 x64 Beta Rendering Performance - Terrible?

    I've got a question out but no reply yet. Gimme a sec, I'll check the web... ...Can't tell for sure at a quick glance.

    Anyway, betas have a way of being debug builds which include lots of extra cruft that will slow things down. From the web it looks like the Win 7b comes in two flavours, a full on debug build with lots of extra processes and no optimizations and maybe even extra data pushing that a compiler will put in to aid in getting info out of the code when needed (good for developers and feedback to MS)... and a more normal use version for people who don't need to get in to the internals so much. The wording of what I read made me believe that this regular folks version does still have some debug material. That could be what is slowing you down.

Closed Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Similar Threads

  1. Price of V-Ray Stand Alone Version?
    By GaryR50 in forum V-Ray
    Replies: 47
    Last Post: January 5th, 2009, 12:36 PM
  2. RC5 out on Tuesday, January 17 2006
    By Maxer in forum Other Renderers
    Replies: 3
    Last Post: January 14th, 2006, 07:59 AM
  3. Replies: 3
    Last Post: August 23rd, 2005, 03:40 AM
  4. Max 6 Rendering Performance
    By dpn in forum 3ds Max
    Replies: 1
    Last Post: August 4th, 2005, 11:01 PM
  5. Speed up rendering from Mac formZ (PC? 3rd Party renderers?)
    By halcy in forum General Discussions
    Replies: 2
    Last Post: June 11th, 2004, 11:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts