Jump to content

Nightmare on Vray street Help


Recommended Posts

guys i was rendering a night version of my last post (in finished work sect)

and all of a sudden every material i have is giving me the warning :material returned overbright or invalid color.

i turned the lights down and F-number up the scene is now too dark and still all the warnings.

a few minutes ago everything was rendering just fine

Pls help i have to deliver this today :o

Link to comment
Share on other sites

Hello Fran it seems i had a tv with the screen as a Vray lightmat and a Plane in frront of it also with a Vray light mat but with a higher Multiplier.they were separated by at least 10 Cm .after i had the weird artifacts and a few crashes (i hate how much Vray crashes) i deleted the plane and now i am rendering.i 'll be posting the results later tonight .it sure would be nice if u took a look ;)

meanwhile if someone had an explanation for this i'd be grateful.

Ps i did this trick before with no Prob.

thank u and take care.

Link to comment
Share on other sites

I've always found the biggest culprit of over-bright materials to be if you have a standard material buried somewhere in your scene. A standard material with a high specular value can cause your error a lot of the time. It's always best to keep all vray materials in a vray scene. But sometimes when I merge in objects from an old scene I'll get a standard material that slips in. Open your material library, sort it by scene and see if you have any standards in there, then check and see how high the specular is set. Turning it down could help, but a better solution would be to convert it to a proper vray material.


Another thing to keep in mind is just because you are changing your f-stop it doesn't really affect how the materials and light are calculated in the scene. So you aren't really darkening down the materials. You are just darkening down how the actual image is exposed in the viewport. Think of it this way.... if you were to shorten your shutter speed the sun's intensity isn't going to get any weaker, your camera just isn't exposing it's full brightness anymore. So in this case changing your camera settings probably isn't leading to the best solution of your problem.

Link to comment
Share on other sites

Dear Brian ur explanation is Impeccable yet simple to grasp quickly (i wish i had a teacher like u in school ;)) but i dought it's an issue of standard material as the warning was naming almost every object in the scene.99.9 of which i think are Vray mat.

i think the problem was as i said to fran upper in the thread although i have no explanation why ????

anyway i posted the results and i'd be honored if u and nic would drop in a line or two and tell me what u think


thank u guys ur the best regards

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...