Jump to content

Export/Geometry Face Issues


Recommended Posts

Basically my professor wants me to bring my MAX file over to FormZ to produce some sections a specific way.


Every file I export (dxf dwg igs 3ds) creates every face as two triangles (or more). I constructed the model with 2d rectangles converted them to editable splines then extruded those.


is there someway to simplify these faces so they are produced without the triangles. I tried converting everything to editable poly and mesh. Also tried applying an optimize modifier. When it is a mesh or poly I can select the individual triangle faces in max. Both formz and rhino show them.


I don't really want to have to redraw this in rhino or formz so any ideas would be great.


I attached a picture that may help explain whats happening here, sorry for the poor graphics I was trying to do this quick.

Link to comment
Share on other sites

They are all triangulated like that in Max. 3d geometry tends to be in terms of triangles. I can't speak for the software or formats you are using in particular, but... hey, if it started as triangles it's going to end up that way. I don't know if any interchange solutions offer hidden edges or how they might be supported or automated on your end platforms.


Ultimately... does it matter? The geometry is still there are you are trying to create a section. Will the section be any less for having been cut through a number of triangles than through a boundary represented polygon of arbitrary shape and topology?

Link to comment
Share on other sites

I guess it matters in the hidden line view, the edges of the triangles are visible. I can probably clean up the sections after.


I also found that exporting as a .obj reduced the triangles to only faces that had more than 4 vertex points so its about 50% better.


Probably just going to redraw it in rhino, its not that complicated of a model, Thanks for looking.

Link to comment
Share on other sites

I solved the problem.


Export as a .stl file.


and make sure you check the join coplanar faces box in FormZ when importing


I still had a few triangled faces but I think its an error in the way I constructed the MAX file, a little clean up should resolve that.


.obj was also pretty good but .stl was best



Edited by JakeH
Link to comment
Share on other sites

As well, you had a really simple scene, so whatever you import.. you can:

-Convert to poly

-Weld vertex

-Optimize modifier, and select option


So this way you do not spend minutes saving over and over again, but a few sec. and a few clicks cleaning in Max anything you got in there.


(Your .stl file still have triangles, but they are hidden)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...