Jump to content

Major Backburner & SpeedTree Rendering Issues


Recommended Posts

First off, this is a two-part problem, and I was not sure which forum to post this in, so move if needed.


First problem is with backburner.

I am just diving into using a renderfarm and so far I haven't had any issues, spare this one.


I am using only 1 machine so far in the renderfarm for testing, and it's the host machine. So basically I have one machine running backburner server, manager, & monitor, and I am net-rendering to myself basically.


Everything seems to work fine, but one scene I am working in has had major issues.

I am using Speedtree, with a few people RPCs, a few lights, & a skydome (not an environment background image).


If i do a straight render without netrender, I get a fine image that I am happy with. If I submit that same scene to netrender, I get a drastically different return.

The skydome is no longer filling up the background but is basically showing the 'plate' and I am missing geometry, it seems to be getting clipped by something.

I have included two images, one rendered from max & one rendered through backburner. One render does not have the sky plate, but you should be able to tell visually the problem I am having when you compare the images.


This is the first issue I am having. Any ideas what would cause this drastic of a difference?


The 2nd is with SpeedTree.


When I open max with a scene that has speedtrees, sometimes the trees will appear 'exploded', where as they are shooting lines everywhere. The only fix I have found for this is to select one of the trees, and hit 'compute'. The trees then 'gather' themselves and appear properly.

This normally wouldnt be too much of an issue, except when I submit to render over backburner, I do not get the chance to re-compute and I get renders with exploded trees. Basically black splines shooting everywhere...


I have no found any help for this issue and I am hoping that it's just a corrupted speedtree file or something. I have tried to just replace it in the past, but I may need to go back and actually re-plant all the exploding trees.


This is becoming really frustrating, and I can't figure out what I should do about the tree issue. I have tried to just replace the tree type with a different .spt file but it hasn't solved the issue. I can only think that those trees are corrupted and need to be deleted and totally re-planted.


I have included 2 images as well for this, one normal render, and one with exploding trees.


Something I also noticed, is that my native graphics engine for 3ds max is Direct3d, but whenever backburner opens a copy of max for rendering with backburner it always uses OpenGL... is this possibly the problem, and is there a way to fix this?


Sorry for the wall of text, I am just having some major issues so i tried to be descriptive... any help is greatly appreciated. Thanks in advance.

Link to comment
Share on other sites

Very descriptive indeed...but post your specs (Max-, Speedtree-, OS-, Displaydriver-version) so people can reproduce this...or not ;) With latest Speedtree 4.2 under Max2008 32bit/64bit under XP/Vista 32/64bit I've never these problems !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...