Jump to content

Light Produced From Emitters is Not Strong.


Recommended Posts



I'm pretty new to Maxwell, certainly no expert, and am having difficulty with emitters. They are producing light, but it is so negligible that it seems to not reach to the floors, etc.


I am using Both the Sketchup and Maxwell plugin free versions - maybe this has something to do with it?


Ive attached some images to demonstrate what I am talking about, showing the render with; no emitters, emitters within the bulb (how I want it to be) and then the emitter moved to varying distances below the bulb to test the strength of the light on the surrounding surfaces. Ive also included the settings I put on the emitter material.


I want the light to shine down onto the counters, floors, walls, etc. when they are within the light fixtures.


Any help would be appreciated.




Edited by adamd1
Link to comment
Share on other sites

Hi Adam, so far so good if you're a beginner.


A few tips:

- Emitters really need dead-simple geometry in order to optimize your quality-vs-speed ratio. So, scrap all the lightbulbs in your scene, and replace them with super simple planar discs. You can still put the discs up inside the recessed areas, but make sure they don't intersect with the sidewalls.

- These emitter discs should be extremely low-poly. Emitter objects gain absolutely nothing from having extra polys, it only slows down their calculation.

- Make sure your camera settings are sensible. Is this supposed to be evening? This room seems like it'd need a relatively long exposure or high ISO value. If your exposure is all set up nicely, then:

- Sometimes we just need insane emitter intensities. Maxwell would have you believe that everything's always real-world, all the time, but it's just not always true. I frequently run into situations where I need 1000watt emitters. So if you know for sure that your setup is A-OK, go ahead and try some insane emitter values.


If you can't seem to get it to work, feel free to send me the scene file and I could have a look.

Link to comment
Share on other sites

Thanks for the helpful info.


I changed the lights to discs, and adjusted the camera settings.


By adjusting the camera settings I was able to make the scene much brighter, though still no reflectance from the lights seems visible on any surfaces. Doing so also really blew out the exterior with over exposure.


If you wouldn't mind looking at the scene that would be great, how can I send it to you?

Link to comment
Share on other sites

After looking at your scene file, I realized the lights are upside down! Remember that emitters are one-sided; they emit in the direction of the geometry's normal. So see if you can 'flip normals' in Sketchup or just go through and literally turn all your discs upside down.

With emitters flipped correctly:



One thing I noticed is that you're probably not gonna see the floor reflections of your recessed lighting just because the camera angle doesn't allow it. So if you move the camera and look at the floor you can see the lights showing up:



I didn't change any emitter values

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...