Jump to content

C4D r9 and Nemetschek Allplan 2004 plug-in


Recommended Posts

I cannot seem to get the Nemetschek Allplan 2004 plug-in for C4D to install to r9 - it works fine with r8.5


The patch recently posted by Maxon for Archicad and Vectorworks and Materials Exchange for CAD users makes no difference to the Allplan version as far as I can tell.


Pending a reply from Nemetschek I wondered if anyone else had come across this problem (Nemetschek are advertising r9 and Allplan 2004 as a combination on their website) ?


TIA for any suggestions.


William Sutherland

Link to comment
Share on other sites

thanks Frosty,


Someone else suggested just copying the plugin from r8.5 over to r9...

but when I tried that it crashed everything ! :rolleyes:


I called Maxon UK in the end and someone there thought that all plug-ins needed recompiling for r9 - however other Allplan 2004 users tell me that the r9 demo works fine - maybe something was changed before the final release?


The helpful soul at Maxon said he would get on to Nemetschek about the plug-in and email it to me if it was available (!)


I wouldn't be so puzzled about this except that Nemetschek are currently promoting Allplan 2004 and C4D r9 as a combination on their German site - so it must work... er, mustn't it... ;)

Link to comment
Share on other sites

Just for the record this is now fixed - by pure chance. :rolleyes:


Not heard anything back from Nemetschek - had an email from Maxon UK about the Vectorworks plug-in ... (!) just saying the VW plug-in should work with r9 (which of course wasn't the question )....


Weird though it may seem I just tried one last time but exported in conventional .c4d format out of Allplan instead of the default of .c4U (which is the update format for the plug-in to work) and Eureka! - r9 springs into life and the plug-in import dialog comes up as if I'd used the .c4U format ... as I say... weird :confused: .

I looked in the plug-ins folder and there was the Allplan_update plug-in which hadn't been there the last time I looked.


Oh, well - it's a result ! :cool:




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...