Jump to content

Strange snapping in Max 7


Brian Cassil
 Share

Recommended Posts

This is going to be a little difficult to explain but here it goes.

 

It seems as though there is some sort of grid snapping going on where I can only move objects in about 1 inch increments even though I don't have snap on. Even when I do have snap on my objects seems to respect this "grid", in other words it doesn't quite snap to the point I'm aiming for. It's even worse in a perspective view where the "gird" seems to be about 50' x 50'. Keep in mind, snap is not on.

 

Even stranger, there seems to be some sort of snapping set for zooming, like the soom is king of "jaggy" when I get in close to objects and continually smoother as I zoom away.

 

It's driving me crazy because I'm baisically relagated to using the transform type in for moving anything now (that seems to be the only thing to override the "grid"), so any help will be greatly appreciated.

Link to comment
Share on other sites

  • Administrators

Hey Brian, yeah I noticed that MAX7 was a bit odd to figure out with the new snapping. I'm not quite sure I understand what you are getting at, but if you post a file and a step by step I can give it a go on my end to see if I can replicate it here.

Link to comment
Share on other sites

Hi Brian,

 

There are 2 main changes in Snaps in R7.

 

1. If you pick an object but no snap was "active" when you picked it, the "Pivot Point" is assumed to be the point of choice. Example: Turn on Snaps, but make sure no single snap type is enabled. Grab an object. See: you grabbed its pivot, even though you haven't specified pivot.

2. The snap now has 2 radius. The larger radius only highlights the snap without making the object "pop" to the target. The smaller radius will define how far you have to be so the object "pops". We called it "Magnet" internally while developing it.

 

What you seem to have is a problem with screen precision. Is your scene far away from the origin or really large?

 

Feel free to ask more questions. I'm interested in your problem, since I haven't seen it before.

 

Alexander

"When in doubt, Ask Google"

Link to comment
Share on other sites

Oops didn't see your post Alex. Yes, screen precision does seems to be the problem. And yes, now that I check I am a very long way from the origin...

 

I just moved everything back to on top of the origin and that did it! Muito Obrigado Alex and Jeff for your quick responses.

 

On a side note, I hate that civil engineers and landscape architects put stuff in auto cad in such crazy locations relative to the origin. It's nice to keep that stuff consistent between autocad and max but in cases like this it makes things a nightmare.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...