Jump to content

Post Production - Max and Photoshop


Recommended Posts



I have been reading this great tutorial on Post Production using Photoshop (see below)

It describes how to set up render passes in a Photoshop file in order to create a beauty pass.




This has brought up a few questions that I would love to have answered.


1. I have saved my render passes as .tga 32 bit files. When I bring them into Photoshop

they open in 8 bit format. Could any one tell me why this is happening? I am thinking that I need these passes to stay in 32bit in order to recreate this composite to look similar to my original before post-production manipulation - am I correct in saying this?


2. I have arranged my passes into layers identical to what this tutorial suggests, however my image looks very different when I compare it to my original also open in Photoshop. (my render - the original from Max retained similar color when I opened it in Photoshop).


I was reading that Linear dodge can appear very different, 32 bit compared to 8 bit.

In the attached images you can see that the first image is the original render from Vray/Max and the second is my PSD composite.


I would appreciate some guidance on this issue. Much appreciated and thanks.



Link to comment
Share on other sites

  • 2 weeks later...

With blend modes like add, screen, dodge, etc... basically the modes that increase brightness, lighter colors, especially whites, hit their max value almost immediately. You need to use a 32 bit color space so that these values can exist below their peak. In a way, by adding whites in lower bit depths, you are clamping the image. 32 bit allows you to maintain your values and merely brighten them up.


Francisco is correct about the EXR format, and for what you are doing, I find the EXR format to be the best, but I would imagine that TGA is fine too, I just don't have experience there.


In after effects you do need to tick the "blend colors using 1.0. gamma" but I believe in PS, because its a linear ADD rather than true ADD, the blend modes works without this setting.

Link to comment
Share on other sites

This information is excellent! Thank you Francisco and Corey, the combination of these two responses has

given me clarity on some of the issues that I have been experiencing. Your explanation was very clear and easy to understand.


Yes, double gamma was used in this project. Now using .exr format and have found that is the way to go. I will try working with the .exr files in Photoshop at 32bit. For some reason I thought that I could only work with the files in 16 bit and was also saving my output .exr files in 16 bit format.


Thanks again.

Link to comment
Share on other sites

  • 11 months later...



i just got here by having almost the same issue as Nigel had one year ago.

I looked up alot of tutorials and infos about creating a beautypass just to have full control of my finalrender...


Anyhow. I read like 100000000 Blogs and tutorials, sat down yesterday around 22h straight andd never got a result that was close to the rgb_color_output.


Thats directly leads to my question:


Which are the correct rendersettings, fileformats and especially colormapping sets to get the beautypass looke like the rgb_color pic in VFB?


In my case the composition should be:


[DiffuseFilter * RawGI] + [DiffuseFilter * RawLightning] + VrayReflection + VrayRefraction + VraySpecular = FINALRENDER


I also tried with [ + 0.2 * 1/Rawshadow] which made the result even worse!


Color Maping: some say tweakin the "dont affect color" option in Vray, which is same as Mode "NONE" in Vray 2.4 is necessary. This just makes no sense to me, as i used CM to clear up the burned out parts of the pic.


Gamma: I used 2.2, 1.0. output in Color Mapping Tab - no difference


FileFormat: I really did everything yesterday. PNGs, JPGs, TGAs, EXRs in all sorts of different Bit-Levels. The closest was exporting as EXR 32bit float and using 2.2 Gamma-Curve on it! Lowres_render_images attached




VFB: Some tutorials adviced to turn off the "display colors in sRGB space". didnt made any difference in the composed result. It felt weird to me anyways


Whatever i changed - the RGBcolor result had always the same look. I didnt get there with my composition even once...


Any advices?



Thanks in advance





Link to comment
Share on other sites

  • 2 weeks later...
  • 9 years later...

With blend modes like add, screen, dodge, and others that increase brightness, the best way to retain the values and brightness of the image is to use a 32-bit color space. This allows the colors to exist below their maximum peak, and prevents them from being "clamped". The EXR format is ideal for this type of work, but the TGA format might work as well. In After Effects, it is necessary to tick "Blend Colors Using 1.0 Gamma," but in Photoshop, because it is a linear ADD rather than a true ADD, blend modes are still effective without this setting.


Or you can get pofessional image retouching service

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...